Unable to log in to TE Service
Incident Report for TimeEdit Status Page
Postmortem

We experienced an issue with SSO, where some users with certain browser languages could not open the login page.

We have now updated the SSO login page, to prevent this error in the future

The services were unavailable between 8:00 and 8:14

Posted Aug 18, 2023 - 10:09 CEST

Resolved
We experienced an issue with SSO, where some users with certain browser languages could not open the login page.
Posted Aug 16, 2023 - 08:00 CEST