Intermittent issues accessing some services

Incident Report for TimeEdit Status Page

Resolved

No further issues during the monitoring period, we consider the implemented fix so have solved all issues.
Posted Mar 28, 2025 - 12:41 CET

Monitoring

We have identified the root cause and have implemented a fix that should solve all the issues. We will continue to monitor the situation to ensure no further disruptions of services.
Posted Mar 28, 2025 - 09:51 CET

Investigating

We are currently seeing some users having intermittent issue to access several parts of our services and are investigating the root cause.
Posted Mar 28, 2025 - 09:22 CET
This incident affected: Europe (Viewer, Reporting, Data Manager, REST API, System Services).