Unable to save or submit forms
Incident Report for TimeEdit Status Page
Resolved
This incident has been resolved.
Posted Mar 07, 2024 - 09:33 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 07, 2024 - 08:39 CET
Investigating
We are currently investigating this issue.
Posted Mar 07, 2024 - 08:32 CET
This incident affected: Europe (Preferences), Australia & New Zealand (Preferences), and Singapore (Preferences).