Service disruption

Incident Report for TimeEdit Status Page

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 17:47 CEST

Investigating

Some services and customers are currently experiencing issues and may be unable to access our platform. We are actively investigating the root cause and working to resolve the disruption as quickly as possible.
Posted Jun 02, 2025 - 17:10 CEST
This incident affected: Europe (Plan, Preferences, Core, AutoPilot, Exam, Viewer, Reserve, Reporting, Data Manager, REST API, SOAP API, System Services).