Problems logging in to certain services on V3 Platform
Incident Report for TimeEdit Status Page
Resolved
The incident has now been resolved. If there are still problems loading Core, please go to https://auth.timeedit.net and log back in.
Posted Mar 01, 2024 - 11:25 CET
Investigating
There is a problem with the login service. We are currently investigating the issue to find a solution
Posted Mar 01, 2024 - 11:11 CET
This incident affected: Europe (Core).